うみブログ

旅行記が主と言いながらも、社会や教育の記事もある雑記ブログ

【WordPress】記事移行した際、一部の記事が真っ白になった!【クラシックエディタで書いていた人は注意!】

どうもこんにちは、かたせうみです。

今、ブログを工事しています。

 

今日の記事は、WordPress同士の記事移動について。

 

記事移動、上手く行ったと思ったら、数記事真っ白で何もない状況に遭遇しました。

 

単純に移行出来なかったとか、抜け落ちてたのかと思い、その記事だけコピペ移動させようと思ったのですが、原因が分かったので、記事にしてみました。

 

心当たりがある方は読んでみてね。

 

 

classiceditor(クラシックエディタ)で書いていた人は注意!

 

こんな人は注意です!

 

昔、クラシックエディタで書いていて、途中からブロックに変更した人は、もしかしたらそれが原因で、真っ白記事があるのかもしれません。

 

まずは、移行先にクラシックエディタと言うプラグインをインストールして、記事が表示されるか試してみてください。

 

表示されたら、ビンゴです。

 

編集画面で、おかしな所はありませんか?

一部、クラシックエディタが挿入されてたりしてませんでしたか?

それか、以前使っていたテーマの、オリジナルブロックなどはありませんか?

 

あ、ありました?

 

では、その箇所を削除して、すぐに書き直しましょう。

 

・・と言いたいとこですが、今後ブロックで記事を書く人は、その前に一度クラシックエディタをブロックに変換するのをお忘れなく・・。

私はこれで直りました。

 

以下は、メンテナンスしてもらっている友人との会話。

 

切れてるけど一番上は「あ、ダメだね」と書いてある⤵

f:id:kataseumi:20210504151202j:plain

 

⤴Twitterのエラーも出てましたが、それは多分Twitterの埋め込みのせいかなと思います。

 

Facebookに関しては、以前テーマ側のアップデートで新機能が追加されています。

きっと、これのせい。

インストールしたテーマのバージョンと合ってなかった。

多分。

 

以下、食い下がる私と友人の会話続き。

 

f:id:kataseumi:20210504151157j:plain

f:id:kataseumi:20210504151143j:plain

f:id:kataseumi:20210504151152j:plain

 

急いだ会話で誤字やひらがな表記が多く、何のことやらって感じですが、ピンとくる人もいるかもしれないので、残しておきます。

 

該当記事には一部Twitterの埋め込みもしていました。

ブロックエディタで埋め込んでいたものもあれば、HTMLで埋め込みをしていたものもあり、サイト内では色々と混在していた模様・・・。

 

また、ツイートが古く、遡れない位のものだったのも災いしたのかもしれません。

 

それから、テーマの中には、頻繁に使う吹き出しやブロックを登録しておく機能があるものが多いのですが、移行先に、元の画像や登録をしたページ、同じURLの画像等が無ければ、参照できずにエラーになります。

 

同じテーマ同士の移行であっても、設定が違うと表示されなくなったりしますので、ご注意ください。

 

記事が真っ白になった!のこれまでの経緯

 

f:id:kataseumi:20210504160131j:plain

 

はてなで書いてる私のブログは、いろ〜んな自分の好きな事を書いている雑記ブログで、それはそれで凄く楽しいのですが、長く続けていると、記事が増えてきて、いくつか独立出来るようなカテゴリーが増えてきます。

 

これを、まとめて別のサイトで立ち上げたいなと思う事も多く、WordPressにいくつか記事を移動させたり、WordPress同士で移動させたりと言うことを、たまにやっています。

 

で、ゴールデンウィークを利用して、WordPress同士のとあるサイトから新しいサイトへ記事を移動させていたのですが・・・

 

移行終了!しかし、5記事位真っ白で見えない!

 

WordPressの場合、記事やブログの引越しは、プラグインを使って比較的簡単に行う事ができます。

 

今回は、同じテーマ同士の移動なので、デザイン修正もなく楽々〜!

 

と思ったら、ここに罠が・・(?)

 

記事を確認していたら、数記事、編集画面が真っ白で、何も見えない!!

 

WordPressではたまにそう言う事があるのですが、今回の症状は、「プレビュー画面では見えるのに(なので、恐らく表面上はそんなに支障がない)、編集画面では全く何も表示されず、一切修正が出来ない!!」

 

と言うもの。

 

なんじゃこりゃ!!

 

f:id:kataseumi:20210504160209j:plain

 

ネットで検索すると、色々と対処方がヒットしますが、私の場合、立ち上げ当初に使っていた「クラシックエディタ」が原因だったようです。

 

「クラシックエディタ」とは、昔のWordPressの編集画面の事です。

 

2、3年前、WordPressは大きくエディターが変更され、今は「ブロックエディター」と言う編集画面で記事を書きます。

 

ブロックエディタというのは、画像や文章、ボックスなどがブロック型になっていて、それを挿入する感じで記事を書いていくのですが、以前のエディタとは似ても似つかぬ別人なもんだから、非常に評判が悪く、以前のエディタのまま書きたい人は、専用のプラグインを入れてそのまま書いているのです。

 

で、私も立ち上げ当初はクラシックエディタで記事を書いてました。

だって、どのサイトもブロックでの書き方解説してなかったんだもん。

  

そして1年位して、『このままではイカン!』と、ブロックでの記事作成に臨みました。

(この頃、新規開発されたブロックエディタ対応のテーマ(STILE )に変えている←超書きやすくてオシャレ)

 

そして今日!

こんなエラーになった訳です。

 

どのテーマやサイトでも起きるエラーではないのかもしれないけど、今回はこんな感じです。

 

サイトメンテをたまにお願いしている友人には、こんな事言われました。

 

「クラシックエディタで書き続けた報い」だと・・。

(ひどい)

 

プログラムって、目に見えているものだけが全てじゃないので、困りますよね・・。

ただ書けばいいってもんじゃないのも悲しい感じです。

・・・、アナログ人間の敗北感・・。

 

それと、今回私は、テーマの販売サイトから最新のテーマをダウンロードしたのではなく(一度購入すると、ログインして何度もダウンロードできる。アップデートは自動なので、新しいサイトを立ち上げない限り、何度もダウンロードする事はありません)自分のPCに格納していたファイルをアップロードさせました。

 

ちょっと古いバージョンでしたが、インストールすれば自動でアップデートしてくれるので『まぁいっか』と思ってました。

 

でもきっと、ここもよくなかったんです。

 

憶測ですが、アップデートで新機能が追加されたり、不具合があるとアップデートの時に修正させるじゃないですか。

そのタイミングのズレみたいなものがあったのじゃないかと思うのです。

 

今回、バージョンが古いテーマをインストールし、そこに記事を入れたため(アップデートはその後行った)新しい記事に対応出来なかったのかもしれないし、アップデートで修正されたバグが、記事にはまだくっついていたのかもしれない。

 

しかし、真っ白になっていた記事の中には、確実にブロックのみで書いたものがありましたし、記事を移行させるにあたり、全部ブロックに変換させていたはず・・。

 

と思っていましたが、蓋を開けてみれば、一部クラシックエディタが残ってた物もあった。

 

結局の所、詳細は分からずじまいでしたが、途中でテーマを変えた事とか、一部の記事にクラシックエディタを差し込んで、無理やりデザインを整えていたものがあったのも、関係あるのかもしれませんね。

 

面倒なので、「バグ」という事で一括りにしましたが・・。

 

もう、何でもかんでもバグのせいだし、プラグインのせい。

 

ブログの引越しや記事移動は、思わぬエラーが出ることもあるけど、以前クラシックエディタで書いていて、全部ブロックに直した人は、移行先でこんなエラーが出ることもあるので、参考にしてくださいね。

 

それではまた。